1

Samstag, 15. Juli 2017, 14:59

Erstellen von Zubehöhrteilen für den Char Designer

Hallo,
ich bin immer noch am Basteln und malen, hab auch schon ein oder zwei Sachen zu meiner Zufriedenheit erstellt oder auch abgeändert ( bei den mitgelieferten Bildchen darf man ja Basteln soweit ich weiß) Heute wollte ich dann ein Zubehöhteil erstellen. Das hat auch gut geklappt soweit, bis ich festegestellt habe das ich es in der über dem Haar Zubehör Sparte haben möchte, soweit ich das verstehe ändert sich ja nur der Name von AccA auf AccB geädert werden, allerdings haut das nicht hin. Ich hänge die Bilderchen mal an, vieleicht seht ihr den Fehler, ich finde ihn nicht.
Spoiler
Attachment 23610Attachment 23611Attachment 23612Attachment 23613Attachment 23614Attachment 23615Attachment 23616Attachment 23617
zum Lesen den Text mit der Maus markieren

2

Sonntag, 16. Juli 2017, 20:23

Das erste was mir auffällt: Deine Colormaps stimmen nicht. Nehmen wir zum Beispiel die SideView-Datei SV_AccB_p11. Die dazugehörige Colormap sollte die Bereiche markieren, die zusammengehören und gemeinsam umgefärbt werden können. Beim lila Hut SV_AccB_p08 ist das einmal der Hutstoff als Hauptfarbe und als Nebenfarbe das Hutband. Schau dir die Datei einfach mal zum Vergleich an.
Ich habe für deine Datei das mal angepasst, die Hauptfarbe markiert und die Datei als 8-Bit-PNG abgespeichert. Wenn Du diese Datei
Attachment 23621

mal einfügst. Solltest Du im Generator die Farbverläufe durchklicken können und eine Änderung sehen.

A propos einfügen: Füg mal nur die Datei SV_AccB_p11, SV_AccB_p11_c, icon_AccB_p11, TV_AccB_p11 und TVD_AccB_p11 ein. Also von den TV(D)-Sets keine Colormaps und die Facegrafik nicht. Wenn Du die Dateien so einfügst, sollte der Generator bei dir klappen. Wenn ich aber die von dir erstellte FG_AccB_p11... noch einfüge, hängt sich der Generator bei mir auf. Bei dir auch? Du schriebst bei dir "haut das nicht hin", aber leider nicht, was genau Du für Probleme hast. Hängt sich bei dir auch der Generator auf?

Also zumindest den Tipp, die Colormaps nochmal zu überarbeiten kann ich dir geben und den Hinweis, dass wohl irgendwas mit der Facegrafik nicht stimmt, aber eine direkte Lösung weiß ich leider nicht. Vielleicht, wenn Du mehr die Probleme beschreibst.

3

Montag, 17. Juli 2017, 07:06

Hallo,
japp genau, er hängt sich auf. Das mit den Umfärben kapier ich nicht so ganz, aber ist in dem Fall auch eher unwichtig, da das betreffende Teil einfach immer weiß ist. Da ich die Teile ohnehin immer für nen bestimmten Zweck erstelle ist umfärben auch nicht nötig, aber wäre schon intressant das hin zu bekommen. Was meinst du mit Facegrafik? meinst du das Bild fürs Fenster? Wenns darum geht das, das Dreieck noch nicht so 100% an der perfekten Stelle ist, das weiß ich, aber wollte erstmal wissen ob es überhaupt geht, ehe ich da ewig Zeit investiere :-). Ja der Maker stellt mich bei jedem neuen Versuch wieder vor neue Fragen, würde zu lange dauern die hier alle zu Posten:-(

4

Montag, 17. Juli 2017, 23:43

Zitat von »Mike44«

Das mit den Umfärben kapier ich nicht so ganz, aber ist in dem Fall auch eher unwichtig, da das betreffende Teil einfach immer weiß ist.
Wenn Du das Umfärben-Feature nicht verwenden möchtest, kannst Du dir alle _p11_c-Dateien sparen. Die brauchst Du nur, damit der Figurenerzeuger versteht, wie er das Umfärben durchzuführen hat. Das macht das ganze schon übersichtlich, wenn dein Zubehörteil keine Colormaps braucht.

Der Figurenerzeuger funktioniert auch, wenn Du keine Facegrafik (FG_AccB_p11_c1_m013.png) drin hast. Probier mal, diese aus dem Generatorordner zu entfernen, ob Du danach (Maker neustarten), dein Zubehörteil verwenden kannst, ohne dass sich der Figurenerzeuger aufhängt. Dann weißt Du zumindest, dass deine Facegrafik das Problem ist.


Davon unabhängig: Ich versuche mal das ganze übersichtlich im Wiki zu dokumentieren, aber das dauert etwas: RPGMakerMV/Character Generator – Scientia


Zitat von »Mike44«

Ja der Maker stellt mich bei jedem neuen Versuch wieder vor neue Fragen, würde zu lange dauern die hier alle zu Posten:-(
Ruhig erstmal selber probieren, aber ansonsten ist das Forum ja genau dafür da, dass man sich untereinander austauscht, Fragen stellt und Fragen beantwortet. :)

5

Dienstag, 18. Juli 2017, 16:53

Hallo,
das entfernen der Farbverlaufsbilder hat nix gebracht, erst das entfernen der Facegrafik, allerdings ist natürlich genau die wichtig für mich :-). Schade werd noch bissel testen, ansonsten muss ich halt anderst vorgehen.
.... Habs grade rausgefunden, war ein blöder benennungsfehler, FG_AccB_p11_c1_m013 hies sie ja, aber dieses m013 war, soweit ich das sehen kann, schon vergeben. die Nummern sind immer c1 bisx_m01bis x, aber jede c-m Kombination gibts nur einmal, habe die Grafik jetzt in FG_AccB_p11_c1_m019 umgetauft und es klappt auch zusammen mit den Farbverlaufsbildern, auch wenn ich da eben nur Nebenfarbe 3 zur Auswahl habe.
Zeigt mal wieder das es meisstens an kleinigkeiten hängt.

Social Bookmarks