MangaEngel

Schlitzohr

  • »MangaEngel« ist der Autor dieses Themas

Motto: Vergeude keine Zeit mit Trauer, Wut und Hass, denn so verschwendest du wertvolle Sekunden deines Lebens.

  • Nachricht senden

1

Donnerstag, 1. Oktober 2009, 21:26

Problem mit Game_Character1

Ich habe eine Map zweimal.
Einmal in einem Probespiel (wo ich es zuerst gemappt habe und schauen wollte, ob es Layerprobleme gibt) und dann im richtigen Spiel.
Und jetzt ist es so, dass es im richtigen Spiel immer diese Fehlermeldung gibt:

Zitat

Script 'Game_Character1' line 274: NoMethodError occurred.
undefined method `*' for nil:NilClass


In einem anderen Thread gab es die selbe Fehlermeldung, die offenbar durch Türen verursacht wurden, die als Bild vom Tileset gemacht wurden. Ich habe allerdings kein Event mit einem Bild aus dem Tileset.
Allerdings sind derzeit 40 Events auf der 100x100 großen Map, es könnte also THEORETISCH einfach ne Überlastung sein. Dann würde sie aber doch vermutlich auch nicht in meinem Probespiel funktionieren.
Auch, wenn ich die Map aus dem Probespiel neu rüberkopiere, kommt dieser Fehler.

Hat wohl jemand eine Idee, wieso es in Spiel 1 klappt und in Spiel 2 so rumblockt?

Neo-Bahamut

Himmelsgleicher

Motto: Wer anderen eine Bratwurst brät, der hat ein Bratwurstbratgerät.

  • Nachricht senden

2

Donnerstag, 1. Oktober 2009, 21:51

Also... in deinem Hauptprojekt gehts, aber in dem Testprojekt nicht?

Der Fehler kommt (müsste kommen), wenn eine Tile-ID abgefragt wird, die nicht existiert.
Es könnte also an den Tileseteinstellungen liegen.

(nur zur Sicherheit, die Zeile ist

Ruby Quellcode

1
  	return z + $game_map.priorities[@tile_id] * 32
, oder?)
Spoiler: Wurstinator
zum Lesen den Text mit der Maus markieren

Spoiler: Lazer-Wurst
zum Lesen den Text mit der Maus markieren

Spoiler: Hallowurst
zum Lesen den Text mit der Maus markieren

MangaEngel

Schlitzohr

  • »MangaEngel« ist der Autor dieses Themas

Motto: Vergeude keine Zeit mit Trauer, Wut und Hass, denn so verschwendest du wertvolle Sekunden deines Lebens.

  • Nachricht senden

3

Donnerstag, 1. Oktober 2009, 22:49

Ja, ist sie.
Aber wie gesagt, ich verstehe das nicht o.o
Selbes Tileset, selbe Map, selbe Events.
Wieso geht es dann in Projekt A, aber nicht in Projekt B...
Hm, ich importier mal das Tile neu.

Ok, immer noch selber Fehler :/
Aber ich habe kein Event, dass auf das Tileset zugreift, da bin ich mir sicher.
Wie hoch ist die Chance, dass der Fehler weggeht, wenn ich alle Events lösche und neu erstelle?

Neo-Bahamut

Himmelsgleicher

Motto: Wer anderen eine Bratwurst brät, der hat ein Bratwurstbratgerät.

  • Nachricht senden

4

Freitag, 2. Oktober 2009, 06:38

1%, wenn du kein Event hast, das Tilegrafiken nutzt.
und ähm... ne höhere Zahl, wenn du derartige Events hast :)
Spoiler: Wurstinator
zum Lesen den Text mit der Maus markieren

Spoiler: Lazer-Wurst
zum Lesen den Text mit der Maus markieren

Spoiler: Hallowurst
zum Lesen den Text mit der Maus markieren

MangaEngel

Schlitzohr

  • »MangaEngel« ist der Autor dieses Themas

Motto: Vergeude keine Zeit mit Trauer, Wut und Hass, denn so verschwendest du wertvolle Sekunden deines Lebens.

  • Nachricht senden

5

Freitag, 2. Oktober 2009, 07:14

Na super xD"
Hm, ok, ich werd einfach mal alle Events durchschauen, evtl. habe ich irgendwo mal eine Dachecke oder so reingesetzt...
Wobei ich mir sicher bin, es auf der Map ohne geschafft zu haben.
Zumal es halt im anderen Spiel funktioniert =__=
Hach, egal, sollte ich aus Verzweiflung alle Events gelöscht haben o.Ä. und es geht immer noch nicht, meld ich mich wieder.

RedLink

Landsknecht

Motto: Faulheit ist Relativ

  • Nachricht senden

6

Freitag, 2. Oktober 2009, 19:35

Kann es nicht an deiner DB liegen.
Das Die Grafik die als Titleset genomen werden soll gar nicht existiert oder falsche Maße hat?
  • Scripter

    Für den MV
  • Mitmacher

    nirgendswo

Ähnliche Themen

Social Bookmarks