1

Sonntag, 30. November 2008, 22:02

Den RPG Maker XP lauffähig machen unter Linux,FreeBSD und Mac OS X mit wine

Hallo,
viele User wollen ja den RPG Maker XP unter Linux nutzen, aber dank einen Bug ist das nicht möglich.
Diese Tutorial wurde testet mit wine-1.1.9, er sollte aber auch für Frühere Versionen geeignet sein.

Schritt 1:

Ladet euch zunächst die Source Datei von winehq.org runter.

http://www.winehq.org/

Schritt 2:

Entpackt diese


Schritt 3:

Öffnet die Datei dlls/user32/menu.c


Sucht nach:

ret = MENU_TrackMenu( hMenu, wFlags | TPM_POPUPMENU, 0, 0, hWnd, lpRect );


Ersetzt es durch:

ret = MENU_TrackMenu( hMenu, wFlags | TPM_POPUPMENU | TPM_ENTERIDLEEX, 0, 0, hWnd, lpRect );
Und speichert die Datei ab.


Schritt 4:

Öffnet die Datei dlls/user32/defwnd.c

Sucht nach:

if (!(GetWindowLongW( hwnd, GWL_STYLE ) & WS_CHILD)) EndMenu();


Ersetzt durch:


EndMenu();

Schritt 5:



Kompiliert das Programm mit ./configure && make depend && make

Schritt 6


Wechselt mit su oder sudo -s zu root und führt:

make install
aus

Schritt 7

Erfreut euch das der Maker geht.
Gamedev-Nation.org - Die freundliche Spieleentwickler Community

I am sick of it to be a beta nerd. So I have decided to become a alpha!

TheBlackSnowcat

Ankömmling

Motto: Hochtrainierte Primatin, auch genannt Psychopathin

  • Nachricht senden

2

Sonntag, 22. März 2009, 19:26

Funktioniert nicht unter Ubuntu 8.04

Wine wird nicht erkannt und schreibt mir bei der Ausführung:

kitty@kitty:~/Desktop/wine-1.1.9$ cd /media/Windows_/Programme/Enterbrain/RPGXP
kitty@kitty:/media/Windows_/Programme/Enterbrain/RPGXP$ wine RPGXP
Could not load Mozilla. HTML rendering will be disabled.
wine: configuration in '/home/kitty/.wine' has been updated.
err:module:import_dll Library rgss102e.dll (which is needed by L"Z:\\media\\Windows_\\Programme\\Enterbrain\\RPGXP\\RPGXP.exe") not found
err:module:LdrInitializeThunk Main exe initialization for L"Z:\\media\\Windows_\\Programme\\Enterbrain\\RPGXP\\RPGXP.exe" failed, status c0000135
kitty@kitty:/media/Windows_/Programme/Enterbrain/RPGXP$

3

Sonntag, 22. März 2009, 19:36

Dir fehlt die Datei:
rgss102e.dll wie man es aus der Fehlermeldung lesen kann.
Gamedev-Nation.org - Die freundliche Spieleentwickler Community

I am sick of it to be a beta nerd. So I have decided to become a alpha!

4

Sonntag, 22. März 2009, 20:31

Lad sie dir irgendwo runter, bzw. sie müsste ja im Installationsverzeichnis sein.
Dann KOPIERE sie in den System32-Ordner von Wine (.wine/windows/system32, bin net ganz sicher).

Falls sie nicht im installationsverzeichnis ist, die gibts auch hier:
http://www.dll-files.com/dllindex/dll-files.shtml?rgss102e
(In den rpgmakerxp.exe und in den System32-ordner rein)
  • sig.main

  • sig.wtf

    (22:42:42) epic: kuma: der schwimmt auch in muschis. ist nur witziger "penis" zu sagen.
    (22:42:43) epic: gnihihi
    (22:42:46) epic: penis
    (22:42:50) epic: hihi
  • sig.frpg.ethwen

    Name: Ethwen
    Rasse: Waldelf
    Alter: 23
    Beruf: Jäger

    Level: 1
    Quest: -
    Party: -

    Inventar:
    Umhängetasche (2/4)
    • 1x Proviant (Wildbret)
    • 1x toter Hase
    • 1x Heiltrank

    Kleine Kräutertasche (1/10)
    • Estragon
    Kupfer: 0

    Ausrüstung:
    • Altes Leinenhemd
    • Zerrissene Leinenhose
    • Großer Köcher (24/30)
    • Langbogen (In der Hand)
    • Messer (Lederscheide)

    Fähigkeiten:
    Aktiv
    Passiv
    Völkerbonus
    Instinkt
    Pfeil vergiften
    Heilkunde
    Schnitzen
    Tarnen
    Kräuterkunde
    Jagd

TheBlackSnowcat

Ankömmling

Motto: Hochtrainierte Primatin, auch genannt Psychopathin

  • Nachricht senden

5

Sonntag, 22. März 2009, 21:21

Hab den RmXP einfach noch mal installiert. Jetzt allerdings schreibt mir Wine den Fehler. dass das RGSS-RTP Standard nicht installiert ist!
Obwohl es ja unter Windows einwandfrei geht.
Habe auch den noch einmal installiert, schreibt mir aber immer noch den Fehler. :(

EDIT: Habe das RTP nochmal mit Wine installiert! Funktioniert jetzt.

Echt Geil! DANKE :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TheBlackSnowcat« (22. März 2009, 21:57)


Social Bookmarks